
American Innovations (AI) is pleased to announce version 1.6 of our Pipeline Compliance System Axis® 
software (PCS Axis®). This document explains how to install PCS Axis in a client/server network with 
support for replication (Figure 1, page 2). The information is intended for the IT System Administrator, 
Database Administrator, and PCS Axis Administrator. 

NOTE: Instructions for installing PCS Axis without replication in a client/server network are available in the 
document entitled PCS Axis v1.6 Client Server New Install without Replication.

Topics in this document include those in the following list:

 PCS Axis Best Practices (page 3)

 Installation Overview (page 10)

 Installation Requirements (page 11)

 Adding the Local Domain User Group (page 14)

 Creating the Publication Share Folder (page 15)

 Restoring the PCS Axis Database and Creating the Publication (page 18)

 Creating a Login for the Publication Database and Setting Permission Roles (page 19)

 Installing the PCS Axis Job Service (page 21)

 Starting PCS Axis Job Service (page 24)

 Installing the PCS Axis Application on a Local Client Computer (page 27)

 Installing PCS Axis on a Subscriber ’s Computer (Remote Client) (page 32)

 Setting Up Users in PCS Axis (Local and Remote Clients) (page 37)

 Installation Checklist (page 39)

 Product Support and Training (page 40)

If you have questions or need assistance with the installation, contact PCS Technical Services using the 
contact information on page 40.

PCS Axis® v1.6 Client/Server New Installation with Replication June 2014
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Figure 1.  PCS Axis Client/Server Installation with Replication/Synchronization
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PCS Axis Best Practices is a series of topics demonstrating best practices for setting up the PCS Axis® 
database and related services on a network server running Microsoft® SQL Server® 2008 R2. Topics 
include those in the following list:

 PCS Axis Job Service

 PCS Axis Database (page 5)

 SQL Server (MSSQLServer) Service (page 8)

PCS Axis Job Service

Run the PCS Axis Job Service under a domain account or a SQL Server account with access to the server 
and PCS Axis database. To set up PCS Axis Job Service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 20). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 2.  Computer Management Console

PCS Axis Best Practices
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3 Right-click PCS Axis Job Service 1.6 and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 21). 

4 Click the Log On tab and select the option This account. 

5 Set up PCS Axis Job Service with a user account to log on as a service using a domain account or 
a SQL Server account with access to the server and PCS Axis database. Type the user name and 
password in the appropriate fields (This account, Password, Confirm Password). You can also 
view a list of appropriate user account by clicking Browse > Advanced > Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
database server and PCS Axis database. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 

Figure 3.  PCS Axis Job Service 1.6 Properties
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PCS Axis Database

Information in this section covers best practices for managing the PCS Axis database using Microsoft® SQL 
Server® Management Studio (SSMS). Topics include those in the following list:

 Setting the Database Owner

 Recommended Autogrowth Setting (page 6)

Setting the Database Owner

To prevent errors from occurring when migrating or restoring the PCS Axis database, or when establishing 
a connection, set the “Owner” of the database using the “sa” account. To set the database “Owner” follow 
these steps: 

1 Start SQL Server Management Studio (SSMS). Click Start > Microsoft SQL Server 2008 R2 > SQL 
Server Management Studio. 

2 Double-click the Databases folder in Object Explorer to open the folder. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the 
Database Properties dialog box (Figure 4). 

4 Select Files in the Select a page navigation panel. 

5 Type sa in the Owner field. Then click OK to save changes and close the dialog box. 

Figure 4.  Database Owner
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Recommended Autogrowth Setting

Information in this section applies to the PCS Axis database and log file. If you are running PCS Axis in a 
client/server network with synchronization, the information also applies to the publication and subscription 
databases. 

Autogrowth indicates how much additional space is allocated when the PCS Axis database and log file 
require more space. Setting Autogrowth properties allow the PCS Axis database and log file to resize 
automatically based on a predetermined percentage. Because the database resizing process is a significant 
drain on computer resources, it is recommended that you set properties in a manner that does not allow 
the database to constantly resize itself. 

NOTE: When using PCS Axis with synchronization, set Autogrowth properties after you create the 
publication and subscription databases. 

To set Autogrowth properties for the database (_dat) and log (_log) files, follow these steps:

1 Start SSMS. Click Start > Microsoft SQL Server 2008 R2 > SQL Server Management Studio.

2 Double-click Databases in Object Explorer. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the Database 
Properties dialog box.

4 Click Files in the Select a page navigation panel (Figure 5). 

Figure 5.  Files - Database Properties
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5 Complete the following steps to set Autogrowth properties for the database (_dat) and log (_log) 
files: 

a Click the … ellipsis button in the Autogrowth column of the database _dat file to open the 
Change Autogrowth dialog box (Figure 6). 

b Click the Enable Autogrowth check box to place a check mark inside the check box. 

c For the File Growth property setting, select the option In Percent and then type 10 in the 
adjacent field. This property setting automatically allocates 10% additional space when the 
database requires more space. 

d Click OK to close the Change Autogrowth dialog box.

e Repeat step 5 for the database _log file. 

f Click OK to close the Database Properties dialog box. Then click File > Exit to exit SSMS. 

Figure 6.  Change Autogrowth
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SQL Server (MSSQLServer) Service

Run the Windows SQL Server (MSSQLSERVER) service under a domain account with access to the PCS 
Axis database. To set up the service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 7). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 7.  Computer Management Console

3 Right-click SQL Server (MSSQLSERVER) and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 8). 

Figure 8.  SQL Server (MSSQLSERVER) Properties
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4 Click the Log On tab and select the option This account. 

5 Set up SQL Server (MSSQLSERVER) with a user account to log on as a service using a domain 
account with access to the PCS Axis database. Type the user name and password in the appropriate 
fields (This account, Password, Confirm Password). You can also view a list of appropriate user 
account by clicking Browse > Advanced > Find Now. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 
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Installation tasks covered in this document include those described in the following list. The term central 
database server is used in this document to refer to a network server or host computer. 

IT System Administrator Tasks:

 Run Windows Computer Management on the central database server to create a local 
domain user group named Axis_Users. Add all PCS Axis users (local and remote clients) in the 
Axis_Users group with appropriate permissions to access the central database server. See 
Adding the Local Domain User Group (page 14). 

 Use Windows Explorer on the central database server to create a share folder for the publication 
snapshot files. These files are a “snapshot” of the publication database and are created at the 
time the publication is created. Set the share folder with read/write permissions for the 
Axis_Users group. See Creating the Publication Share Folder (page 15). 

NOTE: Remaining tasks are completed after Database Administrator (DBA) tasks are completed. 

 Install the PCS Axis Job Service on the same server as the publication database or on a 
separate network server. See Installing the PCS Axis Job Service (page 21). 

 Start PCS Axis Job Service. See Starting PCS Axis Job Service (page 24). 

 Install the PCS Axis application on the local computer of the PCS Axis Administrator and all 
other users (local and remote clients). Use Connection Manager during the installation to set 
the server and database connection to the publication database on the central database server. 
See Installing the PCS Axis Application on a Local Client Computer (page 27) and 
Installing PCS Axis on a Subscriber ’s Computer (Remote Client) (page 32). 

 Install the following items on the computer of all PCS Axis subscribers (remote clients). See 
Installing PCS Axis on a Subscriber ’s Computer (Remote Client), page 32.

 Microsoft® SQL Server® Express 2008 R2 SP2

 PCS Axis application

Database Administrator Tasks:

 Restore the PCS Axis database on the central database server using the backup file provided by 
PCS Technical Services. Run the PCS Axis application to create the publication database on the 
central database server. See Restoring the PCS Axis Database and Creating the Publication 
(page 18)

 Create a new SQL login labeled Axis_Users for the publication database. Set permission roles 
for the Axis_Users login. See Creating a Login for the Publication Database and Setting 
Permission Roles (page 19). 

PCS Axis Administrator Tasks:

Run the PCS Axis application to: add all PCS Axis users in User Management; add all subscribers in 
Synchronization Configuration (remote clients); and then set up the subscription database on the 
computer of all subscribers. See Setting Up Users in PCS Axis (Local and Remote Clients), page 37.

Installation Overview
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Before installing PCS Axis, verify the items in the following list are available and the client and server 
computers meet the system requirements identified in Table 1 (page 12) and Table 2 (page 13). 

NOTE: Unless specified otherwise, client refers to both local client and subscriber (remote client) when 
running PCS Axis with replication in a client/server network. 

 PCS Axis License File: The installation process prompts you for the PCS Axis license file provided 
by AI.

 Bridge Import License File: If your company purchased the optional Bridge add-on to import 
data from a third-party application, activating Bridge import for operation requires the license file 
provided by AI. 

NOTE: A Bridge license file is not required to import data from Bullhorn® Asset Tracker (BAT™) or 
export data from PCS Axis. You can maintain all PCS Axis licenses for your organization in the same 
shared folder location. PCS Axis will request the file and location the first time each user opens the 
PCS Axis application. The Bridge activation key is assigned only once for the PCS Axis database; 
once it is assigned it functions for all users.

 Microsoft® SQL Server® 2008 R2 SP2 Express with Tools: Before installing PCS Axis on a 
remote client computer, download and install SQL Server Express 2008 R2 SP2 from the Microsoft 
website. The installation provides the database engine required to run PCS Axis as a subscriber as 
well as database management tools, such as SQL Server Management Studio (SSMS). See page 4 
for download and installation instructions. 

 PCS Axis Installation File: Install PCS Axis using either the installation DVD provided by AI or the 
installation file downloaded from a location identified in an email from PCS Technical Services. 

 System Requirements: Verify the server and client computers meet the system requirements 
identified in Table 1 (page 12) and Table 2 (page 13). 

Installation Requirements
PCS Axis v1.6 Client/Server New Installation with Replication 11 of 40
pcstechservices@aiworldwide.com

mailto:pcstechservices@aiworldwide.com


Table 1.  Central Database Server Requirements (Client/Server Network)

Properties Minimum Recommended

Processor Intel Itanium or faster Intel Itanium or faster

Processor Speed 1.4 GHz or faster 2.0 GHz or faster

RAM 16 GB 32 GB (see note)

Operating System Windows Server 2008 R2 Windows Server 2008 R2

Relational Database 
Software

SQL Server 2008 R2 SQL Server 2008 R2

Available Disk Space 200 GB 400 GB (see note)

Resolution 1280x1024 1920x1080

NOTES: 

• Larger databases may require more RAM for optimum performance. 

• Consult with your company’s IT personnel or DBA to determine where database backups 
will be created. 

• The PCS Axis database installs on the central database server. If selected in Setup Wizard 
during the installation, the PCS Axis application and job service can also install on the 
central database server. For client computer requirements, see Table 2 (page 13). 
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Table 2.  Client Computer Requirements (Client/Server Network)

Properties Minimum Recommended

Processor Intel Core i5 or faster Intel Core i7 or faster

Processor Speed 1.4 GHz or faster 2.0 GHz or faster

RAM 4 GB 8 GB

Operating System Windows 7 32-bit or 64-bit, 
Service Pack 1 (SP1)

Windows 7 32-bit or 64-bit, 
Service Pack 1 (SP1)

Available Disk Space 10 GB 100 GB

Resolution 1280x1024 1920x1080

Microsoft .NET 
Framework

Version 4.0 (see note) Version 4.0 (see note)

NOTES: 

• Subscriber: SQL Server Express 2008 R2 SP2 is required for remote clients 
(subscribers) with a subscription database. Computers with a subscription database 
should follow the Recommended requirements in the table above (Table 2). Only the 
PCS Axis application and subscription database install on the computer of a 
subscriber (remote client). For more information, see Installing PCS Axis on a 
Subscriber ’s Computer (Remote Client) on page 32. 

• Local Client and Subscriber: If the target computer does not have Microsoft® .NET 
Framework v4.0 installed, the PCS Axis installation automatically installs it. This 
feature requires an active Internet connection to complete the installation of .NET 
Framework v4.0. 

• Local Client: Only the PCS Axis application installs on a local client computer. See 
Table 1 (page 12) for information about the PCS Axis database and job service 
installation on the central database server.  
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Information in this section explains how to add a local domain user group on the central database server 
labeled Axis_Users. By adding the Axis_Users group, all PCS Axis users will have access to the server. The 
following information is intended for the IT System Administrator. 

Complete the following steps on the central database server:

1 Open Computer Management. Click Start > Administrative Tools > Computer Management. 

2 Click to expand System Tools and then Local Users and Groups in the navigation tree. 

3 To add the local domain user group labeled Axis_Users, follow these steps:

a Right-click Groups and select New Group in the shortcut menu to open the New Group dialog 
box (Figure 9). 

b Type Axis_Users in the Group name field and a description for the user group in the 
Description field. 

c Click Add > Advanced > Find Now to view a list of user names. Add all PCS Axis users in the 
Axis_Users group (local and remote users). 

d Click Create and then click Close to close the dialog box. 

4 Continue the installation with the next section titled Creating the Publication Share Folder 
(page 15). 

Figure 9.  Axis_Users Local Domain User Group

Adding the Local Domain User Group
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Information in this section explains how to create a share folder for the publication snapshot files and then 
configure the share folder with read/write permissions for the Axis_Users group created earlier (page 14). 
The following information is intended for the IT System Administrator. 

Complete the following steps:

1 Add a new folder on the central database server labeled AxisSnapshot or something similar.

2 Right-click the share folder and select Properties in the shortcut menu to open the folder 
Properties page. 

3 Click the Sharing tab, then click Share to open the File Sharing dialog box (Figure 10).

4 Share the folder with the local domain user group labeled Axis_Users by clicking the down arrow 
and selecting Axis_Users in the selection list. Then click Add. 

If the group name Axis_Users does not appear in the selection list: 

a Select Find People in the selection list to open the Select Users or Groups dialog box. 

b Click Object Types to open the Object Types dialog box. 

c Click the Group check box, then click OK to return to the File Sharing dialog box. 

d Select Axis_Users in the selection list, then click Add. 

Figure 10.  Publication Share Folder

5 Assign the Axis_Users group Read/Write permissions. Select Axis_Users, then click 
Read/Write in the shortcut menu that opens. 

6 Click Share to share the folder and close the File Sharing dialog box. 

7 Click Advanced Sharing in the Sharing tab of the Properties dialog box to open the Advanced 
Sharing dialog box (Figure 11, page 16).

Creating the Publication Share Folder
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Figure 11.  Advanced Sharing

8 Click the check box Share this folder and then click Permissions to open the Permissions dialog 
box (Figure 12).

9 Select Axis_Users in the Group or user names group box. Then click the Allow check boxes for Full 
Control, Change, and Read in the Permissions group box. A check mark inside an Allow check box 
indicates the permission has been granted as shown in the following figure (Figure 12). 

10 Click Apply and then OK to close the Permissions dialog box. 

11 Click Apply and then OK to close the Advanced Sharing dialog box. Then click Close to close the 
Properties dialog box. 

Figure 12.  Permissions
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12 Complete the following steps to assign Network Service permissions in the Security tab of the 
Properties page: 

a Click the Security tab in the Properties page. Then click Edit to open the Permissions dialog 
box (Figure 13).

b Select NETWORK SERVICE in the group box labeled Group or user names.

c In the group box labeled Permissions for NETWORK SERVICE, click the Allow check box for 
Full control to place a check mark inside the check box. 

d Click OK to close the dialog box. Then click Close to close the Properties page. 

13 After the Database Administrator restores the PCS Axis database on the central database server (see 
page 18), continue the installation with the section entitled Installing the PCS Axis Job Service 
(page 21). 

Figure 13.  Security / Network Service Permissions
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Information in this section is intended for the Database Administrator. The information explains how to:

 Restore the backup file of the PCS Axis database on the central database server.

 Run the PCS Axis application to create the publication database on the central database server. 

 Create a new login labeled Axis_Users for the publication database. Then set permission roles for 
the Axis_Users login. 

Complete the following steps:

1 Start SQL Server Management Studio (SSMS). Restore the PCS Axis database on the central 
database server using the database backup file provided by PCS Technical Services. 

2 After the IT System Administrator installs the PCS Axis application on your local computer, complete 
the following steps to create the publication database:

a Start PCS Axis. Click the Windows  Start button, then click All Programs >  PCS Axis 1.6.

b Click Tools > Options > Synchronization. 

c In the field Synchronization User Group Name, type your company’s domain name and the 
name of the local domain user group created earlier labeled Axis_Users using the format 
Domain Name\Axis_Users. Click Save and then close the Options window. 

d Click Tools > Synchronization > Create Publication to open the Create Publisher dialog box 
(Figure 14). 

Figure 14.  Create Publisher

e Type the server path to the share folder used for the publication snapshot in the field Enter 
Snapshot Path using the format \\ServerName\SnapshotShareFolder. 

f Click  OK to create the publication and add snapshot files in the share folder. 

g Click  OK when the message Publisher Creation Complete displays. Then continue with 
the next section Creating a Login for the Publication Database and Setting Permission 
Roles (page 19). 

Restoring the PCS Axis Database and Creating the Publication
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Information in this section explains how to create a new login labeled Axis_Users for the publication 
database and then set database permissions for the new login. The information is intended for the 
Database Administrator.

Complete the following steps:

1 Start SQL Server Management Studio (SSMS). Connect to the central database server and then 
switch to the PCS Axis publication database. 

2 Click to expand Security, then Logins in the navigation tree of Object Explorer. Right-click Logins 
and select New Login in the shortcut menu to open the Login-New dialog box (Figure 15). 

Figure 15.  Login-New

3 Set the following properties in the General page: 

a Type Axis_Users in the Login name field. If the group name Axis_Users does not appear in the 
selection list, complete the following steps:

(1) Select Find People in the selection list to open the Select Users or Groups dialog box. 

(2) Click Object Types to open the Object Types dialog box. 

(3) Click the Group check box, then click OK to return to the File Sharing dialog box. 

(4) Select Axis_Users in the selection list, then click Add. 

Creating a Login for the Publication Database and Setting Permission Roles
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b Enable the option Windows authentication if it is not enabled.

c Verify master is selected in the Default database field. 

4 Click Server Roles in Select a page and enable the public check box. 

5 Click User Mapping in Select a page and enable the following properties:

a In the group box Users mapped to this login, enable the PCS Axis publication database. 

b In the group box Database role membership for, enable the following properties: 

 Axis_Users

 db_datareader

 db_datawriter

 db_ddladmin

 public

c Click OK to save settings and close the Login-New dialog box. 

Tasks performed by the Database Administrator are now complete. 
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The following information is intended for the IT System Administrator. It explains how to install the PCS 
Axis Job Service on a network server. You can install the service either on the same server as the 
publication database or on a separate network server. 

Complete the following steps: 

1 If you are using the installation DVD to install PCS Axis, insert the DVD in the DVD/CD-ROM drive of 
the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical 
Services, navigate to the location of the installation file. 

NOTE: A single installation file labeled setup.exe is used to install PCS Axis on a 32-bit and 64-bit 
computer. If the target computer does not have Microsoft .NET Framework v4.0 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet connection to 
complete the installation of .NET Framework v4.0. 

2 Double-click the setup.exe installation file to open the PCS Axis dialog box (Figure 16). 

 

Figure 16.  PCS Axis Installation

3 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 17, page 22). 

4 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

Installing the PCS Axis Job Service
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Figure 17.  Setup Wizard

5 Click Next to display Custom Setup (Figure 18). 

6 By default the PCS Axis application is selected for installation. If you are working on the central 
database server and do not want to install the application on the server, click the down arrow in 

 PCS Axis and select the option Entire feature will be unavailable. 

7 By default the PCS Axis Job Service is not selected for installation. To install the service on the 
server, click the down arrow in  PCS Axis Job Service and select the option Entire feature will 
be installed on local hard drive. 

8 Click Next and then click Install to begin the installation. 

Figure 18.  Custom Setup
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When the installation completes and after a short delay, Connection Manager opens 
automatically on top of Setup Wizard (Figure 19). 

9 Complete the following steps in Connection Manager to set Server and Database settings: 

a Type the name of the central database server in the Server field. Or click Select in the Server 
field to select the server in the Select Server dialog box.

b Type the name of the publication database in the Database field. Or click Select in the 
Database field to select the database in the Select Database dialog box.

c Click  Test to verify the connection to the server and database. When the message 
Connection successful displays, click  OK to close the message. 

d Click  Save and Close to exit Connection Manager.

10 Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS Axis 
installation file (setup.exe). 

11 Installation of the PCS Axis Job Service is now complete. Continue with the next section to start 
the service (page 24). 

Figure 19.  Connection Manager
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The purpose of PCS Axis Job Service is to monitor the PCS Axis job queue, initiating jobs as they become 
available. The following procedure explains how to use Windows Services to start PCS Axis Job Service. 
The information is intended for the IT System Administrator. 

Complete the following steps: 

1 If the PCS Axis database and PCS Axis Job Service are installed on two different network servers, 
complete the following steps to set up a user account to log on as a service. The user account must 
have access to the central database server and publication database. 

a Click the Windows Start button  and navigate to Computer. Right-click Computer and 
select Manage in the shortcut menu to open the Computer Management console (Figure 20). 

b Double-click Services and Applications in the left pane of the console. Then click Services 
to display a list of services in the middle pane. 

Figure 20.  Computer Management Console

c Right-click PCS Axis Job Service 1.6 (Figure 20) and select Properties in the shortcut menu 
to open the Properties dialog box (Figure 21, page 25). 

d Click the Log On tab and select the option This account. To set up a user account to log on as 
a service, type the user name and password in the appropriate fields. You can also view a list of 
appropriate user accounts by clicking Browse > Advanced > Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
central database server and PCS Axis database. 

Starting PCS Axis Job Service
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e Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

Figure 21.  PCS Axis Job Service 1.6 Properties

2 Complete the following steps in the Computer Management console to start PCS Axis Job 
Service: 

a Select PCS Axis Job Service 1.6 and then click Start (Figure 22). 

b Click File > Exit to close the Computer Management console. 

Figure 22.  Computer Management Console
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c In PCS Axis, click Tools > Job Service Viewer. Verify the message Running displays in the 
Status field (Figure 23). 

Starting PCS Axis Job Service is now complete. Continue with the next section to install the 
PCS Axis application on local client computers (page 27). 

Figure 23.  Job Service Console
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Information in this section is intended for the IT System Administrator. It explains how to install only the 
PCS Axis application on the computer of local client users. Installing the application on remote client users 
(subscribers) is provided in the next section (page 32). 

Complete the following steps: 

1 If you are using the installation DVD to install PCS Axis, insert the DVD in the DVD/CD-ROM drive of 
the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical 
Services, navigate to the location of the installation file. 

NOTE: A single installation file labeled setup.exe is used to install PCS Axis on a 32-bit and 64-bit 
computer. If the target computer does not have Microsoft .NET Framework v4.0 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet connection to 
complete the installation of .NET Framework v4.0. 

2 Double-click the setup.exe installation file to open the PCS Axis dialog box (Figure 24). 

 

Figure 24.  PCS Axis Installation

3 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 25, page 28). 

4 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

Installing the PCS Axis Application on a Local Client Computer
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Figure 25.  Setup Wizard

5 Click Next to display Custom Setup (Figure 26). 

6 By default the  PCS Axis application is selected for installation. The  PCS Axis Job Service 
should not be selected for installation. Verify selections in Custom Setup match those in the 
following figure (Figure 26). 

7 Click Next and then click Install to begin the installation. 

Figure 26.  Custom Setup
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When the installation completes and after a short delay, Connection Manager opens 
automatically on top of Setup Wizard (Figure 27). 

8 Use Connection Manager to establish a connection to the publication database on the central 
database server as follows:

a Type the name of the central database server in the Server field. Or click Select in the Server 
field to select the server in the Select Server dialog box. 

b Type the name of the publication database in the Database field. Or click Select in the 
Database field to select the database in the Select Database dialog box. 

c Click  Test to verify the connection to the server and database. When the message 
Connection successful displays, click  OK to close the message. Click  Save and Close to 
exit Connection Manager. 

9 Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS Axis 
installation file (setup.exe). 

Figure 27.  Connection Manager

10 Start PCS Axis on the client computer. Click the Windows  Start button, then All Programs > 
 PCS Axis 1.6. 

11 When the Activation Key message opens, click  OK and then locate and select your PCS Axis 
activation key (Figure 28, page 30). 

12 When the License Agreement window opens, click  I Agree. 
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Figure 28.  Activation Key

13 If your company purchased the optional Bridge import add-on, complete the following steps to 
activate the feature for operation:

a Click Tools > Job Service Viewer to open the Job Service Console (Figure 29). 

b Click Activate Bridge Import License. When the Activation Key dialog box opens, navigate to 
the license file and select it. Then click Open to close the dialog box and return to the Job 
Service Console. 

The message Valid displays in the License field. If Not Valid displays instead, contact PCS 
Technical Services for assistance using the contact information on page 40. 

Figure 29.  Job Service Console

14 Open the About window in PCS Axis to view information about the software and database version. 
Click Help > About PCS Axis to open the About window (Figure 30, page 31). 
PCS Axis v1.6 Client/Server New Installation with Replication 30 of 40
pcstechservices@aiworldwide.com

mailto:pcstechservices@aiworldwide.com


NOTE: Clicking Copy To Clipboard in the About window copies the following information to the 
Windows clipboard: network server and database connection; software application version; and 
build information (date and time). After copying information to the clipboard, you can then paste it 
in an email or other type of document, such as Microsoft Word. Use this feature when contacting 
PCS Technical Services for support with PCS Axis.

Figure 30.  About PCS Axis

15 Repeat the steps in this section (pages 27-31) to install the PCS Axis application on all other local 
client computers. 

The local client installation is complete after installing the PCS Axis application on all local client 
computers. Continue with the next section to install PCS Axis on remote client computers 
(subscribers). 
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Information in this section explains how to install the following items on the computer of a remote client 
(subscriber). The information is intended for the IT System Administrator. 

 Microsoft® SQL Server® Express R2 SP2 with Tools

 PCS Axis application

NOTE: Creating and connecting to the subscription database occurs later in the section entitled Setting Up 
Users in PCS Axis (Local and Remote Clients) (page 37).

Complete the following steps:

1 Download and install Microsoft SQL Server Express R2 SP2 with Tools as follows:

a Visit the Microsoft Download Center at http://www.microsoft.com/download/.

b Type SQL Server 2008 R2 SP2 Express Edition in the search bar and then click the  search 
button.

c Click the link Microsoft® SQL Server® 2008 R2 SP2 - Express Edition to open the product 
download page.

NOTE: Information related to the installation is available when clicking the  expand button 
for any of the following items:  Details, System Requirements, Install Instructions, and 
Related Resources. 

d Click Download to open a page with a list of files available for download. 

e If your computer is running the 32-bit version of Windows 7, complete the following steps to 
download and install the installation file labeled SQLEXPRWT_x86_ENU.exe:

(1) Click the check box for the installation file labeled SQLEXPRWT_x86_ENU.exe. Then click 
Next to begin the download. 

(2) To install, double-click the SQLEXPRWT_x86_ENU.exe installation file and follow on-
screen prompts. PCS Axis functions normally with a default installation set up with all 
default options. 

f If your computer is running the 64-bit version of Windows 7, complete the following steps to 
download and install the installation file labeled SQLEXPRWT_x64_ENU.exe:

(1) Click the check box for the installation file labeled SQLEXPRWT_x64_ENU.exe. Then click 
Next to begin the download. 

(2) To install, double-click the SQLEXPRWT_x64_ENU.exe installation file and follow on-
screen prompts. PCS Axis functions normally with a default installation set up with all 
default options. 

Installing PCS Axis on a Subscriber’s Computer (Remote Client)
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2 If you are using the installation DVD to install PCS Axis, insert the DVD in the DVD/CD-ROM drive of 
the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical 
Services, navigate to the location of the installation file. 

NOTE: A single installation file labeled setup.exe is used to install PCS Axis on a 32-bit and 64-bit 
computer. If the target computer does not have Microsoft .NET Framework v4.0 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet connection to 
complete the installation of .NET Framework v4.0. 

3 Double-click the setup.exe installation file to open the PCS Axis dialog box (Figure 31). 

 

Figure 31.  PCS Axis Installation

4 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 32). 

5 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

 

Figure 32.  Setup Wizard
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6 Click Next to display Custom Setup (Figure 33). 

7 By default the PCS Axis application is selected for installation. Click Next and then click Install to 
begin the installation. 

NOTE: Do not install PCS Axis Job Service on a subscriber’s computer. The PCS Axis application 
provides this functionality when using a subscription. 

 

Figure 33.  Custom Setup

When the installation completes and after a short delay, Connection Manager opens 
automatically on top of Setup Wizard (Figure 34, page 35). 

8 Complete the following steps in Connection Manager to establish a connection to the publication 
database on the central database server. 

NOTE: Creating and connecting to the subscription database occurs later in the section entitled 
Setting Up Users in PCS Axis (Local and Remote Clients) (page 37). 

a Type the name of the central database server in the Server field. Or click Select in the Server 
field to select the server in the Select Server dialog box. 

b Type the name of the publication database in the Database field. Or click Select in the 
Database field to select the database in the Select Database dialog box. 

c Click  Test to verify the connection to the server and database. When the message 
Connection successful displays, click  OK to close the message. Click  Save and Close to 
exit Connection Manager. 

9 Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS Axis 
installation file (setup.exe). 
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Figure 34.  Connection Manager

10 Start PCS Axis on the remote client computer. Click the Windows  Start button, then All 
Programs >  PCS Axis 1.6. 

11 When the Activation Key message opens, click  OK and then locate and select your PCS Axis 
activation key (Figure 35). 

12 When the License Agreement window opens, click  I Agree. 

Figure 35.  Activation Key

13 If your company purchased the optional Bridge import add-on, complete the following steps to 
activate the feature for operation:

a Click Tools > Job Service Viewer to open the Job Service Console (Figure 36, page 36). 

b Click Activate Bridge Import License. When the Activation Key dialog box opens, navigate to 
the license file and select it. Then click Open to close the dialog box and return to the Job 
Service Console. 

The message Valid displays in the License field. If Not Valid displays instead, contact PCS 
Technical Services for assistance using the contact information on page 40. 
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Figure 36.  Job Service Console

14 Open the About window in PCS Axis to view information about the software and database version. 
Click Help > About PCS Axis to open the About window (Figure 37). 

NOTE: Clicking Copy To Clipboard in the About window copies the following information to the 
Windows clipboard: database connection; software application version; and build information (date 
and time). After copying information to the clipboard, you can then paste it in an email or other 
type of document, such as Microsoft Word. Use this feature when contacting PCS Technical Services 
for support with PCS Axis.

Figure 37.  About PCS Axis

15 Continue with the next section (page 37) to set up a subscription database on the remote client 
computer (subscriber). 

The remote client installation is complete after installing PCS Axis on the computer of all remote 
clients (subscribers).
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Information in this section is intended for the PCS Axis Administrator. The information explains how to 
complete the following tasks:

 Add all PCS Axis users in User Management (local and remote clients). 

 Add all subscribers in Synchronization Configuration (remote clients). 

 Set up a subscription database on the computer of all subscribers (remote clients). 

Complete the following steps: 

1 Start the PCS Axis application and then click Tools > User Management >  Add. 

2 To add a user in PCS Axis: 

a Type the user's Windows domain user name in the User Name field and then press Tab. PCS 
Axis automatically adds the user's email address. Verify Active is enabled. 

b Update other information as needed, such as a user Role selection. 

c Click  Save and then repeat step 2 for each user you want to add. 

3 To add a subscriber in PCS Axis (remote client):

a Click Tools > Synchronization > Synchronization Configuration > Add to open the Add 
Subscription dialog box (Figure 38). A list of all Windows domain user accounts display in the 
dialog box. 

b Select the user name of the remote client user you want to add as a subscriber and then click 
OK. 

c Repeat step 3 for each remote client user you want to add as a subscriber. 

Figure 38.  Add Subscription

Setting Up Users in PCS Axis (Local and Remote Clients)
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4 To set up a subscription database on the computer of a remote client (subscriber):

a Use PCS Axis Connection Manager to establish a connection to the publication database on 
the central database server. 

b Start PCS Axis and then click Tools > Synchronization > Configure Subscription to open the 
Configure Subscriber dialog box (Figure 39).

c PCS Axis provides the name of the subscriber’s computer in the field Enter Instance Name. 
Include the name of the local SQL server instance in this field using the following format:

ComputerName\LocalSQLServerInstanceName

NOTE: To view the name of the local SQL server instance using Microsoft SQL Server 
Management Studio (SSMS): (1) Start SSMS and connect to the server. (2) Right-click the server 
instance in Object Explorer and select Properties. (3) On the General page, view the SQL 
server instance name in the Name field. 

d The default name of the subscription database set up in system Options (Tools > Options > 
Synchronization) displays in the field Enter Subscription Database Name. If you want to 
change the default name of the subscription database, type a name in this field. 

 

Figure 39.  Configure Subscriber

e Click  OK to begin the configuration process. 

f When the message Subscription Complete Restart displays, click  OK. PCS Axis restarts 
and then connects to the subscription database. 

5 Repeat step 4 as needed to set up a subscription database on the computer of another remote 
client (subscriber). 
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IT System Administrator Tasks

 Create a local domain user group labeled Axis_Users on the central database server. Add PCS 
Axis users to the Axis_Users group who are listed in Windows Active Directory. 

 Create a share folder for the publication snapshot files on the central database server. Set the 
share folder with read/write permissions for the Axis_Users local domain user group. Then set 
Full Control for Network Services in the Security tab. 

NOTE: Remaining IT tasks are completed when Database Administrator tasks are completed.

 Install PCS Axis Job Service on the same server as the publication database or on a separate 
network server. Then use Windows Services to start PCS Axis Job Service. 

 Install the PCS Axis application on the local computer of the Database Administrator, PCS Axis 
Administrator, and all local users (clients). Use PCS Axis Connection Manager during the 
installation to set the server and database connection to the publication database on the central 
database server. 

 Install the Microsoft SQL Server Express 2008 R2 SP2 and the PCS Axis application on the 
computer of all PCS Axis subscribers (remote clients). 

Database Administrator Tasks 

 Restore the PCS Axis database on the central database server. 

 Create a new login for the PCS Axis database labeled Axis_Users. 

 Set the following permission roles for the new login Axis_Users:

 Axis_Users

 db_datareader

 db_datawriter

 db_ddladmin

 public

 Run the PCS Axis application and create the publication database on the central database server. 

PCS Axis Administrator Task

 Use PCS Axis to add all users in User Management (local and remote clients).

 Use PCS Axis to add all subscribers in Synchronization Configuration (remote clients).

 Set up the subscription database on the computer of all subscribers (remote clients). 

Installation Checklist
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If you have a suggestion, question, feature request, or a bug to report-your feedback would be 
appreciated. Also if you have a training need for your organization or would like to know more about 
upcoming PCS Axis training classes, please use any of the following contact information to reach PCS 
Technical Services:

Support E-mail: pcstechservices@aiworldwide.com

Support Telephone: 1-800-229-3404 (select 1, then press 2)

American Innovations: http://www.aiworldwide.com

Product Support and Training
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